summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/wrapup/rtems/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/exec/wrapup/rtems/Makefile.am b/c/src/exec/wrapup/rtems/Makefile.am
new file mode 100644
index 0000000000..d2cadc9a58
--- /dev/null
+++ b/c/src/exec/wrapup/rtems/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = librtems
+LIB = $(ARCH)/$(LIBNAME).a
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+CPU_OBJS = $(wildcard ../../score/cpu/$(RTEMS_CPU)/$(ARCH)/*.rel)
+CORE_OBJS = $(wildcard ../../score/src/$(ARCH)/*.o)
+SAPI_OBJS = $(wildcard ../../sapi/src/$(ARCH)/*.o)
+RTEMS_OBJS = $(wildcard ../../rtems/src/$(ARCH)/*.o)
+
+OBJS = $(CPU_OBJS) $(CORE_OBJS) $(RTEMS_OBJS) $(SAPI_OBJS)
+
+SIZE_RTEMS = $(SHELL) $(PROJECT_ROOT)/tools/cpu/generic/size_rtems
+
+$(LIB): ${OBJS}
+ $(make-library)
+ # cd $(PROJECT_ROOT) ; \
+ $(SIZE_RTEMS) @RTEMS_BSP@ $(ARCH) \
+ >$(PROJECT_RELEASE)/lib/sizeinfo$(LIB_VARIANT).txt
+
+TMPINSTALL_FILES += \
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+all: ${ARCH} $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am