summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/wrapup/posix/Makefile.am')
-rw-r--r--c/src/exec/wrapup/posix/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/c/src/exec/wrapup/posix/Makefile.am b/c/src/exec/wrapup/posix/Makefile.am
index d80634763d..7bcd49438a 100644
--- a/c/src/exec/wrapup/posix/Makefile.am
+++ b/c/src/exec/wrapup/posix/Makefile.am
@@ -6,7 +6,7 @@ AUTOMAKE_OPTIONS = foreign 1.4
if HAS_POSIX
LIBNAME = libposix
-LIB = $(ARCH)/$(LIBNAME).a
+LIB = $(ARCH)/$(LIBNAME).a
endif
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
@@ -21,13 +21,12 @@ OBJS = $(POSIX_OBJS)
$(LIB): ${OBJS}
$(make-library)
-POSIX_LIB = \
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+POSIX_LIB = $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
-all: ${ARCH} $(LIB) $(TMPINSTALL_FILES)
+all-local: ${ARCH} $(LIB) $(TMPINSTALL_FILES)
endif