summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/wrapup/Makefile.am')
-rw-r--r--c/src/exec/wrapup/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/exec/wrapup/Makefile.am b/c/src/exec/wrapup/Makefile.am
index 5d6e917049..4d37763c62 100644
--- a/c/src/exec/wrapup/Makefile.am
+++ b/c/src/exec/wrapup/Makefile.am
@@ -27,8 +27,6 @@ endif
OBJS = $(CPU_OBJS) $(CORE_OBJS) $(RTEMS_OBJS) $(SAPI_OBJS) \
$(POSIX_OBJS) $(ITRON_OBJS)
-SIZE_RTEMS = $(SHELL) $(PROJECT_TOPdir)/tools/cpu/generic/size_rtems
-
$(LIB): ${OBJS}
$(make-library)
@@ -37,6 +35,10 @@ TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT
$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
+install-hook: $(LIB)
+ @$(mkinstalldirs) $(libdir)
+ $(INSTALL_DATA) $(LIB) $(libdir)
+
all-local: ${ARCH} $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am