summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/wrapup/Makefile.am')
-rw-r--r--c/src/exec/wrapup/Makefile.am87
1 files changed, 0 insertions, 87 deletions
diff --git a/c/src/exec/wrapup/Makefile.am b/c/src/exec/wrapup/Makefile.am
deleted file mode 100644
index 1583d3133d..0000000000
--- a/c/src/exec/wrapup/Makefile.am
+++ /dev/null
@@ -1,87 +0,0 @@
-##
-## $Id$
-##
-
-
-LIBNAME = librtemscpu
-LIB = $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a
-
-include $(top_srcdir)/automake/multilib.am
-include $(top_srcdir)/automake/compile.am
-include $(top_srcdir)/automake/lib.am
-
-CPU_OBJS = $(wildcard ../score/cpu/$(RTEMS_CPU)/$(ARCH)/*.rel)
-CORE_OBJS = $(wildcard ../score/src/$(ARCH)/*.o)
-SAPI_OBJS = $(wildcard ../sapi/src/$(ARCH)/*.o)
-RTEMS_OBJS = $(wildcard ../rtems/src/$(ARCH)/*.o)
-
-if HAS_POSIX
-POSIX_OBJS = ../posix/src/$(ARCH)/libposix.a
-endif
-
-if HAS_ITRON
-ITRON_OBJS = ../itron/src/$(ARCH)/libitron.a
-endif
-
-LIBCSUPPORT_OBJS = ../libcsupport/$(ARCH)/libcsupport.a
-
-LIBBLOCK_OBJS = ../libblock/src/$(ARCH)/libblock.a
-if !UNIX
-LIBDOSFS_OBJS = ../libfs/src/dosfs/$(ARCH)/libdosfs.a
-endif
-LIBIMFS_OBJS = ../libfs/src/imfs/$(ARCH)/libimfs.a
-
-if HAS_NETWORKING
-NETWORKING_OBJS = \
- ../libnetworking/wrapup/$(ARCH)/libnetworking.a \
- ../librpc/src/rpc/$(ARCH)/librpc.a \
- ../librpc/src/xdr/$(ARCH)/libxdr.a
-endif
-
-OBJS = $(CPU_OBJS) $(CORE_OBJS) $(RTEMS_OBJS) $(SAPI_OBJS) \
- $(POSIX_OBJS) $(ITRON_OBJS) $(LIBCSUPPORT_OBJS) \
- $(LIBBLOCK_OBJS) $(LIBDOSFS_OBJS) $(LIBIMFS_OBJS) \
- $(NETWORKING_OBJS)
-
-$(LIB): ${OBJS}
- rm -f $@
- test -d $(ARCH) || mkdir $(ARCH)
- rm -rf $(ARCH)/*
- for f in $(OBJS); do \
- case $$f in \
- *.o | *.rel) \
- if test -f $(ARCH)/`basename $$f`; then \
- if cmp $$f $(ARCH)/`basename $$f`; then \
- true; \
- else \
- echo 1>&2 "ERROR -- `basename $$f` in multiple files"; \
- exit 1; \
- fi; \
- else \
- cp $$f $(ARCH)/; \
- chmod a-w $(ARCH)/`basename $$f`; \
- fi; \
- ;; \
- *.a) \
- cd $(ARCH); \
- $(AR) xv ../$$f || exit 1; \
- chmod a-w * ; \
- cd ..; \
- ;; \
- esac; \
- done
- $(AR) rc $@ $(ARCH)/*
- rm -f $(ARCH)/*.o
- $(RANLIB) $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a
-
-#$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
-# $(INSTALL_DATA) $< $@
-
-cpulibdir = $(libdir)
-cpulib_DATA = $(LIB)
-
-all-local: ${ARCH} $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/automake/local.am