summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/macros/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/macros/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/macros/rtems/score/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/exec/score/macros/rtems/score/Makefile.am b/c/src/exec/score/macros/rtems/score/Makefile.am
new file mode 100644
index 0000000000..d5b2fe9ae4
--- /dev/null
+++ b/c/src/exec/score/macros/rtems/score/Makefile.am
@@ -0,0 +1,35 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+EXTRA_DIST = README
+
+if MACROS
+# We only build multiprocessing related files if HAS_MP was defined
+MP_I_PIECES_yes_V = mppkt.inl objectmp.inl threadmp.inl
+MP_I_PIECES = $(MP_I_PIECES_$(HAS_MP)_V)
+
+I_PIECES = address.inl chain.inl coremsg.inl coremutex.inl coresem.inl heap.inl \
+ isr.inl object.inl priority.inl stack.inl states.inl sysstate.inl \
+ thread.inl tod.inl tqdata.inl userext.inl watchdog.inl wkspace.inl \
+ $(MP_I_PIECES)
+
+noinst_HEADERS = $(I_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE) \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/score/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am