summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/macros/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/macros/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/macros/rtems/score/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/c/src/exec/score/macros/rtems/score/Makefile.am b/c/src/exec/score/macros/rtems/score/Makefile.am
index 0ac48e0386..4260e15c08 100644
--- a/c/src/exec/score/macros/rtems/score/Makefile.am
+++ b/c/src/exec/score/macros/rtems/score/Makefile.am
@@ -7,9 +7,10 @@ AUTOMAKE_OPTIONS = foreign 1.4
## We only build multiprocessing related files if HAS_MP was defined
MP_I_FILES = mppkt.inl objectmp.inl threadmp.inl
-STD_I_FILES = address.inl chain.inl coremsg.inl coremutex.inl coresem.inl heap.inl \
- isr.inl object.inl priority.inl stack.inl states.inl sysstate.inl \
- thread.inl tod.inl tqdata.inl userext.inl watchdog.inl wkspace.inl
+STD_I_FILES = address.inl chain.inl coremsg.inl coremutex.inl coresem.inl \
+ heap.inl isr.inl object.inl priority.inl stack.inl states.inl \
+ sysstate.inl thread.inl tod.inl tqdata.inl userext.inl watchdog.inl \
+ wkspace.inl
noinst_HEADERS = $(STD_I_FILES) $(MP_I_FILES)
@@ -20,9 +21,8 @@ else
I_FILES = $(STD_I_FILES
endif
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/score \
-$(I_FILES:%=$(PROJECT_INCLUDE)/rtems/score%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/score%)
$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $@
@@ -30,8 +30,6 @@ $(PROJECT_INCLUDE)/rtems/score/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am