summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/include/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/include/rtems/score/Makefile.am (renamed from c/src/exec/score/include/rtems/score/Makefile.in)66
1 files changed, 27 insertions, 39 deletions
diff --git a/c/src/exec/score/include/rtems/score/Makefile.in b/c/src/exec/score/include/rtems/score/Makefile.am
index 9bcf5b808b..995cd3a01d 100644
--- a/c/src/exec/score/include/rtems/score/Makefile.in
+++ b/c/src/exec/score/include/rtems/score/Makefile.am
@@ -1,44 +1,37 @@
-#
-# $Id$
-#
-
-@SET_MAKE@
-srcdir = @srcdir@
-top_srcdir = @top_srcdir@
-top_builddir = ../../../..
-subdir = score/include/rtems/score
+##
+## $Id$
+##
-RTEMS_ROOT = @RTEMS_ROOT@
-PROJECT_ROOT = @PROJECT_ROOT@
-
-VPATH = @srcdir@
+AUTOMAKE_OPTIONS = foreign 1.4
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(RTEMS_ROOT)/make/leaf.cfg
-INSTALL_CHANGE = @INSTALL_CHANGE@
-mkinstalldirs = $(SHELL) $(top_srcdir)/@RTEMS_TOPdir@/mkinstalldirs
-
-INSTALLDIRS = $(PROJECT_INCLUDE)/rtems/score
-
-$(INSTALLDIRS):
- @$(mkinstalldirs) $(INSTALLDIRS)
-
# We only build multiprocessing related files if HAS_MP was defined
-MP_H_PIECES_yes_V = mpci mppkt objectmp threadmp
-MP_H_PIECES = $(MP_H_PIECES_$(HAS_MP)_V)
+MP_H_FILES = mpci.h mppkt.h objectmp.h threadmp.h
# H_FILES that get installed in the rtems/score subdirectoy
-H_PIECES = address apiext bitfield chain context copyrt coremsg coremutex \
- coresem heap interr isr object priority stack states sysstate thread \
- threadq tod tqdata userext watchdog wkspace $(MP_H_PIECES)
-H_FILES = $(H_PIECES:%=$(srcdir)/%.h)
+STD_H_FILES = address.h apiext.h bitfield.h chain.h context.h copyrt.h coremsg.h \
+ coremutex.h coresem.h heap.h interr.h isr.h object.h priority.h stack.h \
+ states.h sysstate.h thread.h threadq.h tod.h tqdata.h userext.h \
+ watchdog.h wkspace.h
TARGOPTS = targopts.h
-SRCS = $(H_FILES) $(TARGOPTS)
+if HAS_MP
+H_FILES = $(STD_H_FILES) $(TARGOPTS) $(MP_H_FILES)
+else
+H_FILES = $(STD_H_FILES) $(TARGOPTS)
+endif
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/score \
+$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $@
-RTEMS_USE_NEWLIB = @RTEMS_USE_NEWLIB@
-HAS_ITRON_API = @HAS_ITRON_API@
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
#
# Add your list of files to delete here. The config files
@@ -47,8 +40,7 @@ HAS_ITRON_API = @HAS_ITRON_API@
# 'make clobber' already includes 'make clean'
#
-CLEAN_ADDITIONS += $(TARGOPTS)
-CLOBBER_ADDITIONS +=
+CLEANFILES += $(TARGOPTS)
# Until RTEMS_CPU is removed from all the make configuration files,
# this will need to be here to transform hppa1.1 into hppa1_1 to
@@ -104,12 +96,8 @@ $(TARGOPTS):
@echo >>$@
@echo "#endif" >>$@
-all: preinstall
+all: $(PREINSTALL_FILES)
-preinstall: $(INSTALLDIRS) $(H_FILES) $(TARGOPTS)
- @$(INSTALL_CHANGE) -m 644 $(H_FILES) $(PROJECT_INCLUDE)/rtems/score
- @$(INSTALL_CHANGE) -m 644 $(TARGOPTS) $(PROJECT_INCLUDE)/rtems/score
+EXTRA_DIST = $(STD_H_FILES) $(MP_H_FILES)
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+include $(top_srcdir)/../../../automake/local.am