summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/include/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/include/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/include/rtems/score/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/c/src/exec/score/include/rtems/score/Makefile.am b/c/src/exec/score/include/rtems/score/Makefile.am
index 4507d51b33..01468381c6 100644
--- a/c/src/exec/score/include/rtems/score/Makefile.am
+++ b/c/src/exec/score/include/rtems/score/Makefile.am
@@ -11,10 +11,10 @@ include $(RTEMS_ROOT)/make/leaf.cfg
MP_H_FILES = mpci.h mppkt.h objectmp.h threadmp.h
# H_FILES that get installed in the rtems/score subdirectoy
-STD_H_FILES = address.h apiext.h bitfield.h chain.h context.h copyrt.h coremsg.h \
- coremutex.h coresem.h heap.h interr.h isr.h object.h priority.h stack.h \
- states.h sysstate.h thread.h threadq.h tod.h tqdata.h userext.h \
- watchdog.h wkspace.h
+STD_H_FILES = address.h apiext.h bitfield.h chain.h context.h copyrt.h \
+ coremsg.h coremutex.h coresem.h heap.h interr.h isr.h object.h \
+ priority.h stack.h states.h sysstate.h thread.h threadq.h tod.h tqdata.h \
+ userext.h watchdog.h wkspace.h
TARGOPTS = targopts.h
if HAS_MP
@@ -23,9 +23,8 @@ else
H_FILES = $(STD_H_FILES) $(TARGOPTS)
endif
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/score \
-$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $@
@@ -45,7 +44,7 @@ CLEANFILES += $(TARGOPTS)
RTEMS_CPU_DEFINED = $(subst .,_,$(RTEMS_CPU))
# make the target dependent options file
-$(TARGOPTS):
+$(TARGOPTS):
@echo "/* target board dependent options file */" >$@
@echo "/* automatically generated -- DO NOT EDIT!! */" >>$@
@echo >>$@
@@ -89,7 +88,7 @@ $(TARGOPTS):
@echo >>$@
@echo "#endif" >>$@
-all: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
EXTRA_DIST = $(STD_H_FILES) $(MP_H_FILES)