summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/include/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/include/rtems/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/exec/score/include/rtems/Makefile.am b/c/src/exec/score/include/rtems/Makefile.am
index f09b99a313..f4ac2b1717 100644
--- a/c/src/exec/score/include/rtems/Makefile.am
+++ b/c/src/exec/score/include/rtems/Makefile.am
@@ -8,18 +8,15 @@ H_FILES = debug.h system.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/rtems/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
SUBDIRS = score