summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/cpu/unix/rtems/score/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/unix/rtems/score/Makefile.am b/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
new file mode 100644
index 0000000000..06c1e6e614
--- /dev/null
+++ b/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+GENSIZE = $(PROJECT_ROOT)/tools/cpu/unix/gensize
+
+GENERIC_H_FILES = unixsize.h
+STATIC_H_FILES = cpu.h unixtypes.h unix.h
+noinst_HEADERS = $(STATIC_H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+unixsize.h: $(GENSIZE) cpu.h
+ $(RM) $@
+ $(GENSIZE) > $@
+
+CLEANFILES = unixsize.h
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/score \
+$(STATIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h) \
+$(GENERIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am