summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/unix/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/unix/rtems/score/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/exec/score/cpu/unix/rtems/score/Makefile.am b/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
index 899d858130..8b76a65138 100644
--- a/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
+++ b/c/src/exec/score/cpu/unix/rtems/score/Makefile.am
@@ -4,11 +4,12 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_scoredir = $(includedir)/rtems/score
+
GENSIZE = $(PROJECT_TOPdir)/tools/cpu/unix/gensize
GENERIC_H_FILES = unixsize.h
-STATIC_H_FILES = cpu.h unixtypes.h unix.h
-noinst_HEADERS = $(STATIC_H_FILES)
+include_rtems_score_HEADERS = cpu.h unixtypes.h unix.h
#
# (OPTIONAL) Add local stuff here using +=
@@ -21,8 +22,8 @@ unixsize.h: $(GENSIZE) cpu.h
CLEANFILES = unixsize.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(STATIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h) \
- $(GENERIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+ $(GENERIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h) \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
$(PROJECT_INCLUDE)/rtems/score:
$(mkinstalldirs) $@