summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/unix/configure.in')
-rw-r--r--c/src/exec/score/cpu/unix/configure.in47
1 files changed, 47 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/unix/configure.in b/c/src/exec/score/cpu/unix/configure.in
new file mode 100644
index 0000000000..e9ee7b9b9f
--- /dev/null
+++ b/c/src/exec/score/cpu/unix/configure.in
@@ -0,0 +1,47 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(cpu.c)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-unix,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+RTEMS_ENABLE_MULTIPROCESSING
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+RTEMS_CHECK_NEWLIB
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
+
+# The only use of System V IPC is the UNIX port when multiprocessing.
+if test "$HAS_MP" = "yes"; then
+ RTEMS_CHECK_SYSV_UNIX
+fi
+
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
+
+# Try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+rtems/Makefile
+rtems/score/Makefile)