summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/sh/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/sh/rtems/score/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/sh/rtems/score/Makefile.am b/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
new file mode 100644
index 0000000000..cd110b7fc8
--- /dev/null
+++ b/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = cpu.h shtypes.h sh.h sh_io.h isp$(RTEMS_CPU_MODEL).h \
+ io$(RTEMS_CPU_MODEL).h
+noinst_HEADERS = \
+ cpu.h shtypes.h sh.h sh_io.h \
+ iosh7032.h ispsh7032.h \
+ iosh7045.h ispsh7045.h
+
+## HACK: this should not be here
+## Currently needed to get RTEMS_CPU_MODEL
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/score \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am