summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/hppa1.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/hppa1.1/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/hppa1.1/Makefile.am46
1 files changed, 39 insertions, 7 deletions
diff --git a/c/src/exec/score/cpu/hppa1.1/Makefile.am b/c/src/exec/score/cpu/hppa1.1/Makefile.am
index 85f3c7a67c..6a08f979ff 100644
--- a/c/src/exec/score/cpu/hppa1.1/Makefile.am
+++ b/c/src/exec/score/cpu/hppa1.1/Makefile.am
@@ -2,10 +2,37 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = rtems
+include $(top_srcdir)/../../../../../../automake/multilib.am
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+include_HEADERS= asm.h
+PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = \
+ rtems/score/cpu.h \
+ rtems/score/cpu_asm.h \
+ rtems/score/hppa.h \
+ rtems/score/hppatypes.h \
+ rtems/score/offsets.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
@@ -13,10 +40,6 @@ C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
S_FILES = cpu_asm.S
S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
-include $(top_srcdir)/../../../../../../automake/multilib.am
-include $(top_srcdir)/../../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../../automake/lib.am
-
REL = $(ARCH)/rtems-cpu.rel
rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
@@ -33,5 +56,14 @@ all-local: $(ARCH) $(rtems_cpu_rel_OBJECTS) $(REL) \
EXTRA_DIST = cpu.c cpu_asm.S rtems.S
-include $(top_srcdir)/../../../../../../automake/subdirs.am
+# FIXME: We should get rid of genoffsets
+GENOFFSETS = $(PROJECT_TOPdir)/tools/cpu/hppa1.1/genoffsets
+
+GENERIC_H_FILES = rtems/score/offsets.h
+rtems/score/offsets.h: $(GENOFFSETS) cpu.h
+ @(mkinstalldirs) rtems/score
+ $(RM) $@
+ $(GENOFFSETS) > $@
+CLEANFILES = rtems/score/offsets.h
+
include $(top_srcdir)/../../../../../../automake/local.am