summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/a29k/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/a29k/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/a29k/rtems/score/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/a29k/rtems/score/Makefile.am b/c/src/exec/score/cpu/a29k/rtems/score/Makefile.am
new file mode 100644
index 0000000000..5ec1ac9f61
--- /dev/null
+++ b/c/src/exec/score/cpu/a29k/rtems/score/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = a29k.h a29ktypes.h cpu.h cpu_asm.h
+noinst_HEADERS = $(H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/score \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am