summaryrefslogtreecommitdiffstats
path: root/c/src/exec/sapi/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/sapi/src/Makefile.am')
-rw-r--r--c/src/exec/sapi/src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/exec/sapi/src/Makefile.am b/c/src/exec/sapi/src/Makefile.am
new file mode 100644
index 0000000000..d4c32b0ee7
--- /dev/null
+++ b/c/src/exec/sapi/src/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+C_FILES = debug.c entrytable.c extension.c fatal.c exinit.c io.c itronapi.c \
+ posixapi.c rtemsapi.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D__RTEMS_INSIDE__
+AM_CFLAGS += $(CFLAGS_OS_V)
+
+all: ${ARCH} ${OBJS}
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../automake/local.am