summaryrefslogtreecommitdiffstats
path: root/c/src/exec/sapi/macros/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/sapi/macros/rtems/Makefile.am')
-rw-r--r--c/src/exec/sapi/macros/rtems/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/exec/sapi/macros/rtems/Makefile.am b/c/src/exec/sapi/macros/rtems/Makefile.am
new file mode 100644
index 0000000000..761fac6c2e
--- /dev/null
+++ b/c/src/exec/sapi/macros/rtems/Makefile.am
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if MACROS
+I_PIECES = extension.inl
+
+noinst_HEADERS = $(I_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am