summaryrefslogtreecommitdiffstats
path: root/c/src/exec/sapi/macros/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/sapi/macros/rtems/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/exec/sapi/macros/rtems/Makefile.am b/c/src/exec/sapi/macros/rtems/Makefile.am
index 991f6865b2..857ad0615c 100644
--- a/c/src/exec/sapi/macros/rtems/Makefile.am
+++ b/c/src/exec/sapi/macros/rtems/Makefile.am
@@ -9,9 +9,8 @@ I_FILES = extension.inl
noinst_HEADERS = $(I_FILES)
if MACROS
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@
@@ -19,8 +18,6 @@ $(PROJECT_INCLUDE)/rtems/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am