summaryrefslogtreecommitdiffstats
path: root/c/src/exec/sapi/include/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/sapi/include/rtems/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/c/src/exec/sapi/include/rtems/Makefile.am b/c/src/exec/sapi/include/rtems/Makefile.am
index deabd8b0b5..0483ede4c3 100644
--- a/c/src/exec/sapi/include/rtems/Makefile.am
+++ b/c/src/exec/sapi/include/rtems/Makefile.am
@@ -5,13 +5,12 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = config.h directives.h extension.h fatal.h init.h io.h mptables.h \
- sptables.h
+ sptables.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@
@@ -20,8 +19,6 @@ $(PROJECT_INCLUDE)/rtems/%.h: %.h
EXTRA_DIST = README
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am