summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/macros/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/macros/rtems/rtems/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/exec/rtems/macros/rtems/rtems/Makefile.am b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
new file mode 100644
index 0000000000..9cc8e6d810
--- /dev/null
+++ b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
@@ -0,0 +1,28 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if MACROS
+I_PIECES = asr.inl attr.inl dpmem.inl event.inl eventset.inl message.inl \
+ modes.inl options.inl part.inl ratemon.inl \
+ region.inl sem.inl status.inl support.inl tasks.inl timer.inl
+
+noinst_HEADERS = $(I_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/rtems \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+
+$(PROJECT_INCLUDE)/rtems/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/rtems/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am