summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/macros/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/macros/rtems/rtems/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/c/src/exec/rtems/macros/rtems/rtems/Makefile.am b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
index 65e0594cfd..dacf3011fe 100644
--- a/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
@@ -5,16 +5,15 @@
AUTOMAKE_OPTIONS = foreign 1.4
I_FILES = asr.inl attr.inl dpmem.inl event.inl eventset.inl message.inl \
- modes.inl options.inl part.inl ratemon.inl \
- region.inl sem.inl status.inl support.inl tasks.inl timer.inl
+ modes.inl options.inl part.inl ratemon.inl region.inl sem.inl status.inl \
+ support.inl tasks.inl timer.inl
noinst_HEADERS = $(I_FILES)
if MACROS
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/rtems \
-$(I_FILES:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@
@@ -22,8 +21,6 @@ $(PROJECT_INCLUDE)/rtems/rtems/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am