summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/inline/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/inline/rtems/rtems/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/c/src/exec/rtems/inline/rtems/rtems/Makefile.am b/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
index 44dde4db1b..b8b787a40e 100644
--- a/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
@@ -6,14 +6,13 @@ AUTOMAKE_OPTIONS = foreign 1.4
if INLINE
I_FILES = asr.inl attr.inl dpmem.inl event.inl eventset.inl message.inl \
- modes.inl options.inl part.inl ratemon.inl \
- region.inl sem.inl status.inl support.inl tasks.inl timer.inl
+ modes.inl options.inl part.inl ratemon.inl region.inl sem.inl status.inl \
+ support.inl tasks.inl timer.inl
noinst_HEADERS = $(I_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/rtems \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@
@@ -21,8 +20,6 @@ $(PROJECT_INCLUDE)/rtems/rtems/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am