summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/include/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/rtems/include/rtems/rtems/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/c/src/exec/rtems/include/rtems/rtems/Makefile.am b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
index 4afbdd0695..cbd214e1aa 100644
--- a/c/src/exec/rtems/include/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
@@ -5,20 +5,24 @@
AUTOMAKE_OPTIONS = foreign 1.4
## We only build multiprocessing related files if HAS_MP was defined
-if HAS_MP
MP_H_FILES = eventmp.h mp.h msgmp.h partmp.h regionmp.h semmp.h \
signalmp.h taskmp.h
-endif
-H_FILES = asr.h attr.h clock.h config.h dpmem.h event.h eventset.h intr.h \
+STD_H_FILES = asr.h attr.h clock.h config.h dpmem.h event.h eventset.h intr.h \
message.h modes.h options.h part.h ratemon.h region.h rtemsapi.h sem.h \
- signal.h status.h support.h tasks.h timer.h types.h $(MP_H_FILES)
+ signal.h status.h support.h tasks.h timer.h types.h
+
+if HAS_MP
+H_FILES = $(STD_HFILES) $(MP_H_FILES)
+else
+H_FILES = $(STD_H_FILES)
+endif
-noinst_HEADERS = $(H_FILES)
+noinst_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
PREINSTALL_FILES = \
$(PROJECT_INCLUDE)/rtems/rtems \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@