summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/include/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/include/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/include/rtems/rtems/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/c/src/exec/rtems/include/rtems/rtems/Makefile.am b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
index 94667686bd..4afbdd0695 100644
--- a/c/src/exec/rtems/include/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
@@ -5,17 +5,18 @@
AUTOMAKE_OPTIONS = foreign 1.4
## We only build multiprocessing related files if HAS_MP was defined
-MP_H_PIECES_yes_V = eventmp.h mp.h msgmp.h partmp.h regionmp.h semmp.h \
+if HAS_MP
+MP_H_FILES = eventmp.h mp.h msgmp.h partmp.h regionmp.h semmp.h \
signalmp.h taskmp.h
-MP_H_PIECES = $(MP_H_PIECES_$(HAS_MP)_V)
+endif
-H_PIECES = asr.h attr.h clock.h config.h dpmem.h event.h eventset.h intr.h \
+H_FILES = asr.h attr.h clock.h config.h dpmem.h event.h eventset.h intr.h \
message.h modes.h options.h part.h ratemon.h region.h rtemsapi.h sem.h \
- signal.h status.h support.h tasks.h timer.h types.h $(MP_H_PIECES)
+ signal.h status.h support.h tasks.h timer.h types.h $(MP_H_FILES)
-noinst_HEADERS = $(H_PIECES)
+noinst_HEADERS = $(H_FILES)
-TMPINSTALL_FILES = \
+PREINSTALL_FILES = \
$(PROJECT_INCLUDE)/rtems/rtems \
$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
@@ -24,8 +25,8 @@ $(PROJECT_INCLUDE)/rtems/rtems:
$(PROJECT_INCLUDE)/rtems/rtems/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(TMPINSTALL_FILES)
-debug-am: $(TMPINSTALL_FILES)
-profile-am: $(TMPINSTALL_FILES)
+all-am: $(PREINSTALL_FILES)
+debug-am: $(PREINSTALL_FILES)
+profile-am: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am