summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/optman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/posix/optman/Makefile.am24
1 files changed, 18 insertions, 6 deletions
diff --git a/c/src/exec/posix/optman/Makefile.am b/c/src/exec/posix/optman/Makefile.am
index 99da45f754..bf02adffdd 100644
--- a/c/src/exec/posix/optman/Makefile.am
+++ b/c/src/exec/posix/optman/Makefile.am
@@ -5,18 +5,30 @@
AUTOMAKE_OPTIONS = foreign 1.4
C_FILES =
-H_FILES =
-
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
-SRCS = $(C_FILES)
-OBJS = $(C_O_FILES)
-
PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/../../../../automake/lib.am
+
+TMPINSTALL_FILES += \
+$(C_FILES:%.c=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
+
+$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
AM_CFLAGS += $(CFLAGS_OS_V)
+ASM4FLAGS += -I$(PROJECT_INCLUDE)/rtems
+
+all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGMS)
+
+EXTRA_DIST = $(C_FILES)
include $(top_srcdir)/../../../../automake/local.am