summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/macros/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/macros/rtems/posix/Makefile.am')
-rw-r--r--c/src/exec/posix/macros/rtems/posix/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/exec/posix/macros/rtems/posix/Makefile.am b/c/src/exec/posix/macros/rtems/posix/Makefile.am
new file mode 100644
index 0000000000..597f6a59c7
--- /dev/null
+++ b/c/src/exec/posix/macros/rtems/posix/Makefile.am
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if MACROS
+I_PIECES =
+
+noinst_HEADERS = $(I_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/posix \
+$(I_PIECES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+
+$(PROJECT_INCLUDE)/rtems/posix:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/posix/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../automake/local.am