summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/macros/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/posix/macros/rtems/posix/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/exec/posix/macros/rtems/posix/Makefile.am b/c/src/exec/posix/macros/rtems/posix/Makefile.am
index 32f810b57c..48f00c8a30 100644
--- a/c/src/exec/posix/macros/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/macros/rtems/posix/Makefile.am
@@ -9,9 +9,8 @@ I_FILES =
noinst_HEADERS = $(I_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/posix \
-$(I_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
$(PROJECT_INCLUDE)/rtems/posix:
@$(mkinstalldirs) $@
@@ -19,8 +18,6 @@ $(PROJECT_INCLUDE)/rtems/posix/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../automake/local.am