summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/inline/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/inline/rtems/posix/Makefile.am')
-rw-r--r--c/src/exec/posix/inline/rtems/posix/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/c/src/exec/posix/inline/rtems/posix/Makefile.am b/c/src/exec/posix/inline/rtems/posix/Makefile.am
index 89b3c87d3b..a38f1fa8f1 100644
--- a/c/src/exec/posix/inline/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/inline/rtems/posix/Makefile.am
@@ -3,16 +3,16 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
+
#I_FILES= intr.inl
I_FILES = cond.inl key.inl mqueue.inl mutex.inl pthread.inl priority.inl \
- semaphore.inl
+ semaphore.inl
noinst_HEADERS = $(I_FILES)
if INLINE
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/posix \
-$(I_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
$(PROJECT_INCLUDE)/rtems/posix:
@$(mkinstalldirs) $@
@@ -20,9 +20,7 @@ $(PROJECT_INCLUDE)/rtems/posix/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
EXTRA_DIST = intr.inl