summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/include/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/include/rtems/posix/Makefile.am')
-rw-r--r--c/src/exec/posix/include/rtems/posix/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/c/src/exec/posix/include/rtems/posix/Makefile.am b/c/src/exec/posix/include/rtems/posix/Makefile.am
index 59bf3c281d..96b9bad59b 100644
--- a/c/src/exec/posix/include/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/include/rtems/posix/Makefile.am
@@ -4,17 +4,21 @@
AUTOMAKE_OPTIONS = foreign 1.4
-if HAS_MP
-## We only build multiprocessing related files if HAS_MP was defined
MP_H_FILES = condmp.h mqueuemp.h mutexmp.h pthreadmp.h semaphoremp.h
-endif
-H_FILES = cancel.h cond.h config.h key.h mqueue.h mutex.h posixapi.h \
+STD_H_FILES = cancel.h cond.h config.h key.h mqueue.h mutex.h posixapi.h \
priority.h psignal.h pthread.h ptimer.h semaphore.h seterr.h threadsup.h \
time.h timer.h $(MP_H_FILES)
-#H_FILES= intr.h threadsup.h time.h
-noinst_HEADERS = $(H_FILES)
+UNUSED_H_FILES= intr.h threadsup.h
+
+if HAS_MP
+H_FILES = $(STD_H_FILES) $(MP_H_FILES)
+else
+H_FILES = $(STD_H_FILES)
+endif
+
+noinst_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
PREINSTALL_FILES = \
$(PROJECT_INCLUDE)/rtems/posix \
@@ -29,4 +33,6 @@ all-am: $(PREINSTALL_FILES)
debug-am: $(PREINSTALL_FILES)
profile-am: $(PREINSTALL_FILES)
+EXTRA_DIST = $(UNUSED_H_FILES)
+
include $(top_srcdir)/../../../../automake/local.am