summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/include/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/posix/include/rtems/posix/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/c/src/exec/posix/include/rtems/posix/Makefile.am b/c/src/exec/posix/include/rtems/posix/Makefile.am
index 96b9bad59b..c66a0015c9 100644
--- a/c/src/exec/posix/include/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/include/rtems/posix/Makefile.am
@@ -10,7 +10,7 @@ STD_H_FILES = cancel.h cond.h config.h key.h mqueue.h mutex.h posixapi.h \
priority.h psignal.h pthread.h ptimer.h semaphore.h seterr.h threadsup.h \
time.h timer.h $(MP_H_FILES)
-UNUSED_H_FILES= intr.h threadsup.h
+UNUSED_H_FILES = intr.h threadsup.h
if HAS_MP
H_FILES = $(STD_H_FILES) $(MP_H_FILES)
@@ -20,18 +20,15 @@ endif
noinst_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/posix \
-$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
$(PROJECT_INCLUDE)/rtems/posix:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/rtems/posix/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
EXTRA_DIST = $(UNUSED_H_FILES)