summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/include/rtems/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/include/rtems/posix/Makefile.am')
-rw-r--r--c/src/exec/posix/include/rtems/posix/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/c/src/exec/posix/include/rtems/posix/Makefile.am b/c/src/exec/posix/include/rtems/posix/Makefile.am
index accf79b5ed..59bf3c281d 100644
--- a/c/src/exec/posix/include/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/include/rtems/posix/Makefile.am
@@ -4,28 +4,29 @@
AUTOMAKE_OPTIONS = foreign 1.4
+if HAS_MP
## We only build multiprocessing related files if HAS_MP was defined
-MP_H_PIECES_yes_V = condmp.h mqueuemp.h mutexmp.h pthreadmp.h semaphoremp.h
-MP_H_PIECES = $(MP_H_PIECES_$(HAS_MP)_V)
+MP_H_FILES = condmp.h mqueuemp.h mutexmp.h pthreadmp.h semaphoremp.h
+endif
-H_PIECES = cancel.h cond.h config.h key.h mqueue.h mutex.h posixapi.h \
+H_FILES = cancel.h cond.h config.h key.h mqueue.h mutex.h posixapi.h \
priority.h psignal.h pthread.h ptimer.h semaphore.h seterr.h threadsup.h \
- time.h timer.h $(MP_H_PIECES)
-#H_PIECES= intr.h threadsup.h time.h
+ time.h timer.h $(MP_H_FILES)
+#H_FILES= intr.h threadsup.h time.h
-noinst_HEADERS = $(H_PIECES)
+noinst_HEADERS = $(H_FILES)
-TMPINSTALL_FILES = \
+PREINSTALL_FILES = \
$(PROJECT_INCLUDE)/rtems/posix \
-$(H_PIECES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
$(PROJECT_INCLUDE)/rtems/posix:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/rtems/posix/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(TMPINSTALL_FILES)
-debug-am: $(TMPINSTALL_FILES)
-profile-am: $(TMPINSTALL_FILES)
+all-am: $(PREINSTALL_FILES)
+debug-am: $(PREINSTALL_FILES)
+profile-am: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../automake/local.am