summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/configure.in')
-rw-r--r--c/src/exec/posix/configure.in86
1 files changed, 86 insertions, 0 deletions
diff --git a/c/src/exec/posix/configure.in b/c/src/exec/posix/configure.in
new file mode 100644
index 0000000000..1d3b214ee5
--- /dev/null
+++ b/c/src/exec/posix/configure.in
@@ -0,0 +1,86 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(optman)
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-posix,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_MULTIPROCESSING
+RTEMS_ENABLE_POSIX
+RTEMS_ENABLE_INLINES
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+## FIXME: needed for INSTALL_CHANGE in autoconf subdirectories
+RTEMS_PATH_KSH
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
+RTEMS_CHECK_POSIX_API(RTEMS_BSP)
+
+# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
+if test "$RTEMS_USE_MACROS" = "yes"; then
+ INLINEdir="macros"
+ if test "$HAS_POSIX_API" = "yes"; then
+ # The problem is that there is currently no code in posix/macros :)
+ AC_MSG_ERROR(Macros are not implemented for the POSIX API)
+ fi
+else
+ INLINEdir="inline"
+fi
+AM_CONDITIONAL(INLINE,test "$INLINEdir" = "inline" )
+AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
+
+## Needed when using automake for libs/rels
+RTEMS_CHECK_NEWLIB
+
+## Refuse to build if bsp does not support libposix
+if test "$HAS_POSIX_API" != "yes"; then
+AC_MSG_ERROR([BSP $RTEMS_BSP does not support libposix])
+fi
+
+# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
+if test "$RTEMS_USE_MACROS" = "yes"; then
+# The problem is that there is currently no code in posix/macros :)
+AC_MSG_ERROR(Macros are not implemented for the POSIX API)
+fi
+
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
+
+##
+## FIXME: We configure and build the macros subdirectory, too.
+## Should probably use AM_CONDITIONALs to disable them in future
+# Try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+src/Makefile
+include/Makefile
+include/sys/Makefile
+include/rtems/Makefile
+include/rtems/posix/Makefile
+optman/Makefile
+inline/Makefile
+inline/rtems/Makefile
+inline/rtems/posix/Makefile
+macros/Makefile
+macros/rtems/Makefile
+macros/rtems/posix/Makefile
+)