summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/posix/configure.in')
-rw-r--r--c/src/exec/posix/configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/c/src/exec/posix/configure.in b/c/src/exec/posix/configure.in
index 69ac564fda..4151c6f80d 100644
--- a/c/src/exec/posix/configure.in
+++ b/c/src/exec/posix/configure.in
@@ -31,10 +31,6 @@ RTEMS_CHECK_POSIX_API(RTEMS_BSP)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
INLINEdir="macros"
- if test "$HAS_POSIX_API" = "yes"; then
- # The problem is that there is currently no code in posix/macros :)
- AC_MSG_ERROR(Macros are not implemented for the POSIX API)
- fi
else
INLINEdir="inline"
fi
@@ -50,12 +46,6 @@ if test "$HAS_POSIX_API" != "yes"; then
AC_MSG_ERROR([BSP $RTEMS_BSP does not support libposix])
fi
-# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
-if test "$RTEMS_USE_MACROS" = "yes"; then
-# The problem is that there is currently no code in posix/macros :)
-AC_MSG_ERROR(Macros are not implemented for the POSIX API)
-fi
-
# Explicitly list all Makefiles here
AC_OUTPUT(
Makefile