summaryrefslogtreecommitdiffstats
path: root/c/src/exec/librpc/include/rpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/librpc/include/rpc/Makefile.am')
-rw-r--r--c/src/exec/librpc/include/rpc/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/exec/librpc/include/rpc/Makefile.am b/c/src/exec/librpc/include/rpc/Makefile.am
new file mode 100644
index 0000000000..2b89842fd7
--- /dev/null
+++ b/c/src/exec/librpc/include/rpc/Makefile.am
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if HAS_NETWORKING
+H_PIECES = auth.h rpc.h svc.h types.h clnt.h rpc_msg.h svc_auth.h xdr.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rpc \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rpc/%)
+
+$(PROJECT_INCLUDE)/rpc:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rpc/%.h: %.h
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am