summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/libnetworking/sys/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/c/src/exec/libnetworking/sys/Makefile.am b/c/src/exec/libnetworking/sys/Makefile.am
index 3fe88aff59..07888ddcc7 100644
--- a/c/src/exec/libnetworking/sys/Makefile.am
+++ b/c/src/exec/libnetworking/sys/Makefile.am
@@ -4,10 +4,22 @@
AUTOMAKE_OPTIONS = foreign 1.4
-EXTRA_DIST = buf.h callout.h cdefs.h conf.h domain.h filio.h ioccom.h \
+H_FILES = buf.h callout.h cdefs.h conf.h domain.h filio.h ioccom.h \
ioctl.h kernel.h libkern.h malloc.h mbuf.h mount.h param.h proc.h \
protosw.h queue.h reboot.h resourcevar.h rtprio.h select.h signalvar.h \
socket.h socketvar.h sockio.h sysctl.h syslimits.h syslog.h systm.h \
- ttycom.h ttydefaults.h ucred.h uio.h
+ ttycom.h ttydefaults.h ucred.h uio.h un.h
+
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+
+$(PROJECT_INCLUDE)/sys:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/sys/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am