summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/libnetworking/rtems/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/c/src/exec/libnetworking/rtems/Makefile.am b/c/src/exec/libnetworking/rtems/Makefile.am
index 6626ad39f9..47846d1c4f 100644
--- a/c/src/exec/libnetworking/rtems/Makefile.am
+++ b/c/src/exec/libnetworking/rtems/Makefile.am
@@ -4,6 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
+
+
+include_rtemsdir = $(includedir)/rtems
+
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
@@ -15,12 +19,10 @@ C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
-H_FILES = rtems_bsdnet.h rtems_bsdnet_internal.h tftp.h
-
-noinst_HEADERS = $(H_FILES)
+include_rtems_HEADERS = rtems_bsdnet.h rtems_bsdnet_internal.h tftp.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
- $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@