summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/net/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libnetworking/net/Makefile.am')
-rw-r--r--c/src/exec/libnetworking/net/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/c/src/exec/libnetworking/net/Makefile.am b/c/src/exec/libnetworking/net/Makefile.am
deleted file mode 100644
index 7490585015..0000000000
--- a/c/src/exec/libnetworking/net/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-##
-## $Id$
-##
-
-
-include_netdir = $(includedir)/net
-
-LIBNAME = lib.a
-LIB = $(ARCH)/$(LIBNAME)
-
-C_FILES = if.c if_ethersubr.c if_loop.c radix.c route.c rtsock.c raw_cb.c \
- raw_usrreq.c if_ppp.c ppp_tty.c pppcompress.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/../automake/multilib.am
-include $(top_srcdir)/../automake/compile.am
-include $(top_srcdir)/../automake/lib.am
-
-#
-# Add local stuff here using +=
-#
-
-AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
- -DBOOTP_COMPAT
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
-
-.PRECIOUS: $(LIB)
-
-EXTRA_DIST = if.c if_ethersubr.c if_loop.c radix.c raw_cb.c raw_usrreq.c \
- route.c rtsock.c
-
-include_net_HEADERS = bpf.h ethernet.h if.h if_arp.h if_dl.h if_llc.h if_ppp.h \
- if_types.h netisr.h ppp-comp.h ppp_defs.h radix.h raw_cb.h route.h \
- if_pppvar.h pppcompress.h
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/net \
- $(include_net_HEADERS:%=$(PROJECT_INCLUDE)/net/%)
-
-$(PROJECT_INCLUDE)/net:
- @$(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/net/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-include $(top_srcdir)/../automake/local.am