summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/machine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/libnetworking/machine/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c/src/exec/libnetworking/machine/Makefile.am b/c/src/exec/libnetworking/machine/Makefile.am
index e703d0b82b..8dda8e015f 100644
--- a/c/src/exec/libnetworking/machine/Makefile.am
+++ b/c/src/exec/libnetworking/machine/Makefile.am
@@ -4,13 +4,13 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = conf.h cpu.h cpufunc.h endian.h in_cksum.h limits.h param.h \
- types.h vmparam.h
+include_machinedir = $(includedir)/machine
-noinst_HEADERS = $(H_FILES)
+include_machine_HEADERS = conf.h cpu.h cpufunc.h endian.h in_cksum.h limits.h param.h \
+ types.h vmparam.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/machine \
- $(H_FILES:%=$(PROJECT_INCLUDE)/machine/%)
+ $(include_machine_HEADERS:%=$(PROJECT_INCLUDE)/machine/%)
$(PROJECT_INCLUDE)/machine:
@$(mkinstalldirs) $@