summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libcsupport/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libcsupport/src/Makefile.am')
-rw-r--r--c/src/exec/libcsupport/src/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/c/src/exec/libcsupport/src/Makefile.am b/c/src/exec/libcsupport/src/Makefile.am
index ab08e9f43c..630522af4c 100644
--- a/c/src/exec/libcsupport/src/Makefile.am
+++ b/c/src/exec/libcsupport/src/Makefile.am
@@ -2,6 +2,9 @@
## $Id$
##
+include $(top_srcdir)/../../../automake/multilib.am
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
LIBNAME = libcsupport
LIB = ${ARCH}/${LIBNAME}.a
@@ -36,7 +39,7 @@ PASSWORD_GROUP_C_FILES = getpwent.c getgrent.c
TERMINAL_IDENTIFICATION_C_FILES = ctermid.c isatty.c ttyname.c ttyname_r.c
LIBC_GLUE_C_FILES = __getpid.c __gettod.c __times.c truncate.c access.c \
- stat.c lstat.c pathconf.c newlibc.c no_posix.c no_libc.c
+ stat.c lstat.c pathconf.c newlibc.c no_posix.c no_libc.c utsname.c
UNIX_LIBC_C_FILES = unixlibc.c hosterr.c
@@ -57,10 +60,6 @@ C_FILES = $(COMMON_C_FILES) $(EMBEDDED_C_FILES)
endif
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a
OBJS = $(C_O_FILES)