summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libblock/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libblock/src/Makefile.am')
-rw-r--r--c/src/exec/libblock/src/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/c/src/exec/libblock/src/Makefile.am b/c/src/exec/libblock/src/Makefile.am
new file mode 100644
index 0000000000..4b563282df
--- /dev/null
+++ b/c/src/exec/libblock/src/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+LIBNAME = libblock
+LIB = ${ARCH}/${LIBNAME}.a
+
+C_FILES = bdbuf.c blkdev.c diskdevs.c ramdisk.c
+
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+AM_CFLAGS += $(LIBC_DEFINES)
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+all-local: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am