summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/include/rtems/itron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/itron/include/rtems/itron/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/c/src/exec/itron/include/rtems/itron/Makefile.am b/c/src/exec/itron/include/rtems/itron/Makefile.am
index 542ea135fd..96053cfb9a 100644
--- a/c/src/exec/itron/include/rtems/itron/Makefile.am
+++ b/c/src/exec/itron/include/rtems/itron/Makefile.am
@@ -5,23 +5,20 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = config.h eventflags.h fmempool.h intr.h itronapi.h mbox.h \
- msgbuffer.h network.h object.h port.h semaphore.h sysmgmt.h \
- task.h time.h vmempool.h
+ msgbuffer.h network.h object.h port.h semaphore.h sysmgmt.h task.h \
+ time.h vmempool.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/itron \
-$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
$(PROJECT_INCLUDE)/rtems/itron:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/rtems/itron/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
EXTRA_DIST = README