summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/include/itronsys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/include/itronsys/Makefile.am')
-rw-r--r--c/src/exec/itron/include/itronsys/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/c/src/exec/itron/include/itronsys/Makefile.am b/c/src/exec/itron/include/itronsys/Makefile.am
index 25bcd64a2a..2aa2a0b0ea 100644
--- a/c/src/exec/itron/include/itronsys/Makefile.am
+++ b/c/src/exec/itron/include/itronsys/Makefile.am
@@ -4,22 +4,19 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = eventflags.h fmempool.h intr.h mbox.h msgbuffer.h network.h \
- port.h semaphore.h status.h sysmgmt.h task.h time.h types.h vmempool.h
+H_FILES = eventflags.h fmempool.h intr.h mbox.h msgbuffer.h network.h port.h \
+ semaphore.h status.h sysmgmt.h task.h time.h types.h vmempool.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/itronsys \
-$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/itronsys/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/itronsys \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/itronsys/%)
$(PROJECT_INCLUDE)/itronsys:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/itronsys/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../automake/local.am