summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/include/itronsys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/include/itronsys/Makefile.am')
-rw-r--r--c/src/exec/itron/include/itronsys/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/itron/include/itronsys/Makefile.am b/c/src/exec/itron/include/itronsys/Makefile.am
new file mode 100644
index 0000000000..c7a7286285
--- /dev/null
+++ b/c/src/exec/itron/include/itronsys/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_PIECES = eventflags.h fmempool.h intr.h mbox.h msgbuffer.h network.h \
+ port.h semaphore.h status.h sysmgmt.h task.h time.h types.h vmempool.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/itronsys \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/itronsys/%)
+
+$(PROJECT_INCLUDE)/itronsys:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/itronsys/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../automake/local.am