summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/itron/include/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/c/src/exec/itron/include/Makefile.am b/c/src/exec/itron/include/Makefile.am
new file mode 100644
index 0000000000..f83468dd1b
--- /dev/null
+++ b/c/src/exec/itron/include/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_PIECES = itron.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE) \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+SUBDIRS = rtems itronsys
+
+include $(top_srcdir)/../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../automake/local.am