summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/itron/configure.in78
1 files changed, 78 insertions, 0 deletions
diff --git a/c/src/exec/itron/configure.in b/c/src/exec/itron/configure.in
new file mode 100644
index 0000000000..c1bf5e6e1c
--- /dev/null
+++ b/c/src/exec/itron/configure.in
@@ -0,0 +1,78 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(include/itronsys)
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-itron,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_MULTIPROCESSING
+RTEMS_ENABLE_ITRON
+RTEMS_ENABLE_INLINES
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+## FIXME: needed for INSTALL_CHANGE in autoconf subdirectories
+RTEMS_PATH_KSH
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
+RTEMS_CHECK_ITRON_API(RTEMS_BSP)
+
+# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
+if test "$RTEMS_USE_MACROS" = "yes"; then
+ INLINEdir="macros"
+ if test "$HAS_ITRON_API" = "yes"; then
+ # The problem is that there is currently no code in itron/macros :)
+ AC_MSG_ERROR(Macros are not implemented for the ITRON API)
+ fi
+else
+ INLINEdir="inline"
+fi
+AM_CONDITIONAL(INLINE,test "$INLINEdir" = "inline" )
+AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
+
+## Needed when using automake for libs/rels
+RTEMS_CHECK_NEWLIB
+
+# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
+if test "$RTEMS_USE_MACROS" = "yes"; then
+# The problem is that there is currently no code in itron/macros :)
+AC_MSG_ERROR(Macros are not implemented for the ITRON API)
+fi
+
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
+
+##
+## FIXME: We configure and build the macros subdirectory, too.
+## Should probably use AM_CONDITIONALs to disable them in future
+# Try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+src/Makefile
+include/Makefile
+include/itronsys/Makefile
+include/rtems/Makefile
+include/rtems/itron/Makefile
+inline/Makefile
+inline/rtems/Makefile
+inline/rtems/itron/Makefile
+)
+