summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/itron/configure.ac (renamed from c/src/exec/itron/configure.in)17
1 files changed, 9 insertions, 8 deletions
diff --git a/c/src/exec/itron/configure.in b/c/src/exec/itron/configure.ac
index fb2edb5a66..9d28b050b1 100644
--- a/c/src/exec/itron/configure.in
+++ b/c/src/exec/itron/configure.ac
@@ -1,9 +1,10 @@
-dnl Process this file with autoconf to produce a configure script.
-dnl
-dnl $Id$
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
-AC_PREREQ(2.13)
-AC_INIT(include/itronsys)
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([include/itronsys])
RTEMS_TOP(../../../..)
AC_CONFIG_AUX_DIR(../../../..)
@@ -45,8 +46,7 @@ AM_CONFIG_HEADER(src/config.h)
## FIXME: We configure and build the macros subdirectory, too.
## Should probably use AM_CONDITIONALs to disable them in future
# Explicitly list all Makefiles here
-AC_OUTPUT(
-Makefile
+AC_CONFIG_FILES([Makefile
src/Makefile
include/Makefile
include/itronsys/Makefile
@@ -58,5 +58,6 @@ inline/rtems/itron/Makefile
macros/Makefile
macros/rtems/Makefile
macros/rtems/itron/Makefile
-)
+])
+AC_OUTPUT