summaryrefslogtreecommitdiffstats
path: root/c/src/exec/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/configure.in')
-rw-r--r--c/src/exec/configure.in83
1 files changed, 31 insertions, 52 deletions
diff --git a/c/src/exec/configure.in b/c/src/exec/configure.in
index f92a7bb3ae..11d946929d 100644
--- a/c/src/exec/configure.in
+++ b/c/src/exec/configure.in
@@ -7,24 +7,18 @@ AC_INIT(score)
RTEMS_TOP(../../..)
AC_CONFIG_AUX_DIR(../../..)
-AC_PROG_MAKE_SET
RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-exec,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENABLE_POSIX
-RTEMS_ENABLE_NETWORKING
RTEMS_ENABLE_INLINES
-RTEMS_ENABLE_CXX
RTEMS_ENABLE_GCC28
RTEMS_ENABLE_LIBCDIR
RTEMS_ENV_RTEMSBSP
-AC_PROG_LN_S
-AC_PROG_INSTALL
-RTEMS_PATH_KSH
-
RTEMS_CHECK_CPU
RTEMS_CANONICAL_HOST
@@ -32,14 +26,8 @@ RTEMS_PROJECT_ROOT
dnl check target cc
RTEMS_PROG_CC_FOR_TARGET
-
RTEMS_CANONICALIZE_TOOLS
-dnl if this is an i386, does gas have good code16 support?
-RTEMS_I386_GAS_CODE16
-
-RTEMS_CHECK_SYSV_UNIX
-
RTEMS_CHECK_NEWLIB
# Check if there is custom/*.cfg for this BSP
@@ -47,45 +35,31 @@ RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_CHECK_POSIX_API(RTEMS_BSP)
-# find all the Executive Makefiles
-RTEMS_CHECK_MAKEFILE(score/cpu/$RTEMS_CPU)
-
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
- inline_dir="macros"
+ INLINEdir="macros"
if test "$HAS_POSIX_API" = "yes"; then
# The problem is that there is currently no code in posix/macros :)
AC_MSG_ERROR(Macros are not implemented for the POSIX API)
fi
else
- inline_dir="inline"
+ INLINEdir="inline"
fi
+AM_CONDITIONAL(INLINE,test "$INLINEdir" = "inline" )
+AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
-if test "$HAS_POSIX_API" = "yes"; then
- makefiles="$makefiles posix/Makefile"
- makefiles="$makefiles posix/src/Makefile"
- makefiles="$makefiles posix/include/Makefile"
- makefiles="$makefiles posix/include/sys/Makefile"
- makefiles="$makefiles posix/include/rtems/Makefile"
- makefiles="$makefiles posix/include/rtems/posix/Makefile"
- makefiles="$makefiles posix/include/wrap/Makefile"
- makefiles="$makefiles posix/optman/Makefile"
- makefiles="$makefiles wrapup/posix/Makefile"
+AC_SUBST(RTEMS_VERSION)
- makefiles="$makefiles posix/${inline_dir}/Makefile"
- makefiles="$makefiles posix/${inline_dir}/rtems/Makefile"
- makefiles="$makefiles posix/${inline_dir}/rtems/posix/Makefile"
-fi
+AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
-AC_SUBST(RTEMS_VERSION)
+if test "$HAS_POSIX_API" = "yes"; then
+cfg_subdirs="posix"
+fi
+AC_CONFIG_SUBDIRS($cfg_subdirs)
+AC_CONFIG_SUBDIRS(score/cpu)
-AC_SUBST(rtems_cv_prog_cc_cross)
-AC_SUBST(RTEMS_USE_GCC272)
-AC_SUBST(program_prefix)
-AC_SUBST(CC_CFLAGS_DEFAULT)
-AC_SUBST(CC_CFLAGS_DEBUG_V)
-AC_SUBST(CC_CFLAGS_PROFILE_V)
-AC_SUBST(CC_LDFLAGS_PROFILE_V)
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
# Try to explicitly list a Makefile here
AC_OUTPUT(
@@ -93,33 +67,38 @@ Makefile
rtems/Makefile
rtems/src/Makefile
rtems/include/Makefile
-rtems/include/wrap/Makefile
rtems/include/rtems/Makefile
rtems/include/rtems/rtems/Makefile
rtems/optman/Makefile
-rtems/${inline_dir}/Makefile
-rtems/${inline_dir}/rtems/Makefile
-rtems/${inline_dir}/rtems/rtems/Makefile
+rtems/inline/Makefile
+rtems/inline/rtems/Makefile
+rtems/inline/rtems/rtems/Makefile
+rtems/macros/Makefile
+rtems/macros/rtems/Makefile
+rtems/macros/rtems/rtems/Makefile
sapi/Makefile
sapi/src/Makefile
sapi/include/Makefile
-sapi/include/wrap/Makefile
sapi/include/rtems/Makefile
sapi/include/rtems/sptables.h
-sapi/${inline_dir}/Makefile
-sapi/${inline_dir}/rtems/Makefile
+sapi/inline/Makefile
+sapi/inline/rtems/Makefile
+sapi/macros/Makefile
+sapi/macros/rtems/Makefile
sapi/optman/Makefile
score/Makefile
score/cpu/Makefile
score/include/Makefile
score/include/rtems/Makefile
-score/include/rtems/wrap/Makefile
score/include/rtems/score/Makefile
-score/${inline_dir}/Makefile
-score/${inline_dir}/rtems/Makefile
-score/${inline_dir}/rtems/score/Makefile
+score/inline/Makefile
+score/inline/rtems/Makefile
+score/inline/rtems/score/Makefile
+score/macros/Makefile
+score/macros/rtems/Makefile
+score/macros/rtems/score/Makefile
score/src/Makefile
wrapup/Makefile
wrapup/rtems/Makefile
-$makefiles
+wrapup/posix/Makefile
)