summaryrefslogtreecommitdiffstats
path: root/c/src/exec/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/exec/configure.in b/c/src/exec/configure.in
index 8b8f5d23b3..f92a7bb3ae 100644
--- a/c/src/exec/configure.in
+++ b/c/src/exec/configure.in
@@ -33,11 +33,6 @@ RTEMS_PROJECT_ROOT
dnl check target cc
RTEMS_PROG_CC_FOR_TARGET
-dnl check for g++
-if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
- RTEMS_PROG_CXX_FOR_TARGET
-fi
-
RTEMS_CANONICALIZE_TOOLS
dnl if this is an i386, does gas have good code16 support?
@@ -49,8 +44,8 @@ RTEMS_CHECK_NEWLIB
# Check if there is custom/*.cfg for this BSP
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
-
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
+RTEMS_CHECK_POSIX_API(RTEMS_BSP)
# find all the Executive Makefiles
RTEMS_CHECK_MAKEFILE(score/cpu/$RTEMS_CPU)
@@ -58,7 +53,7 @@ RTEMS_CHECK_MAKEFILE(score/cpu/$RTEMS_CPU)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
inline_dir="macros"
- if test "$RTEMS_HAS_POSIX_API" = "yes"; then
+ if test "$HAS_POSIX_API" = "yes"; then
# The problem is that there is currently no code in posix/macros :)
AC_MSG_ERROR(Macros are not implemented for the POSIX API)
fi
@@ -66,7 +61,7 @@ else
inline_dir="inline"
fi
-if test "$RTEMS_HAS_POSIX_API" = "yes"; then
+if test "$HAS_POSIX_API" = "yes"; then
makefiles="$makefiles posix/Makefile"
makefiles="$makefiles posix/src/Makefile"
makefiles="$makefiles posix/include/Makefile"
@@ -85,7 +80,6 @@ fi
AC_SUBST(RTEMS_VERSION)
AC_SUBST(rtems_cv_prog_cc_cross)
-AC_SUBST(RTEMS_HAS_CPLUSPLUS)
AC_SUBST(RTEMS_USE_GCC272)
AC_SUBST(program_prefix)
AC_SUBST(CC_CFLAGS_DEFAULT)
@@ -129,4 +123,3 @@ wrapup/Makefile
wrapup/rtems/Makefile
$makefiles
)
-