summaryrefslogtreecommitdiffstats
path: root/c/src/exec/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/exec/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/c/src/exec/configure.in b/c/src/exec/configure.in
index 11d946929d..8701a1c634 100644
--- a/c/src/exec/configure.in
+++ b/c/src/exec/configure.in
@@ -13,6 +13,7 @@ AM_INIT_AUTOMAKE(rtems-c-src-exec,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENABLE_POSIX
+RTEMS_ENABLE_ITRON
RTEMS_ENABLE_INLINES
RTEMS_ENABLE_GCC28
RTEMS_ENABLE_LIBCDIR
@@ -34,6 +35,7 @@ RTEMS_CHECK_NEWLIB
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_CHECK_POSIX_API(RTEMS_BSP)
+RTEMS_CHECK_ITRON_API(RTEMS_BSP)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
@@ -42,6 +44,10 @@ if test "$RTEMS_USE_MACROS" = "yes"; then
# The problem is that there is currently no code in posix/macros :)
AC_MSG_ERROR(Macros are not implemented for the POSIX API)
fi
+ if test "$HAS_ITRON_API" = "yes"; then
+ # The problem is that there is currently no code in itron/macros :)
+ AC_MSG_ERROR(Macros are not implemented for the ITRON API)
+ fi
else
INLINEdir="inline"
fi
@@ -51,9 +57,13 @@ AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
AC_SUBST(RTEMS_VERSION)
AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
+AM_CONDITIONAL(HAS_ITRON,test "$HAS_ITRON_API" = "yes")
if test "$HAS_POSIX_API" = "yes"; then
-cfg_subdirs="posix"
+ cfg_subdirs="posix"
+fi
+if test "$HAS_ITRON_API" = "yes"; then
+ cfg_subdirs="$cfg_subdirs itron"
fi
AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_CONFIG_SUBDIRS(score/cpu)
@@ -100,5 +110,6 @@ score/macros/rtems/score/Makefile
score/src/Makefile
wrapup/Makefile
wrapup/rtems/Makefile
+wrapup/itron/Makefile
wrapup/posix/Makefile
)