summaryrefslogtreecommitdiffstats
path: root/c/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/Makefile.am')
-rw-r--r--c/src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/c/src/Makefile.am b/c/src/Makefile.am
index 28c11c13d8..23cabcfc63 100644
--- a/c/src/Makefile.am
+++ b/c/src/Makefile.am
@@ -4,7 +4,7 @@
ACLOCAL_AMFLAGS = -I ../../aclocal
-SUBDIRS = @BSP_SUBDIRS@
+SUBDIRS = . @BSP_SUBDIRS@
clean-local:
$(RM) -r $(PROJECT_RELEASE)
@@ -31,5 +31,12 @@ make/custom/%.cfg: $(srcdir)/$(cfg_dir)/custom/%.cfg
noinst_DATA += make/custom/default.cfg
DISTCLEANFILES += make/custom/default.cfg
+noinst_DATA += preinstall-stamp
+
+preinstall-stamp:
+ $(MAKE) $(AM_MAKEFLAGS) preinstall
+ touch preinstall-stamp
+CLEANFILES = preinstall-stamp
+
include $(top_srcdir)/../../automake/subdirs.am
include $(top_srcdir)/../../automake/host.am